|
GETTING STARTED GUIDE

NI-DAQ"mx Base 1.x

This guide describes how to install and configure the NI-DAQmx Base 1.x
software and a data acquisition (DAQ) device. This guide also describes
how to verify that the device is operating properly.

@ Note For information about NI-DAQmx Base for Linux and Mac OS, refer to
ni.com/info and enter rddgld.
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Conventions

The following conventions are used in this guide.

» The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

@ This icon denotes a tip, which alerts you to advisory information.
@ This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take

to avoid injury, data loss, or a system crash. When this symbol is marked
on the device, refer to the Read Me First: Safety and Radio-Frequency
Interference document, shipped with the device, for precautions to take.

bold Bold text denotes items that you must select or click in the software,
such as menu items and dialog box options.

italic Italic text denotes a cross reference, an introduction to a key concept,
or a placeholder for a word or value that you must supply.
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monospace Text in this font denotes text or characters you should enter from the
keyboard, the proper names of disk drives, paths, directories, programs,
functions, filenames, and extensions.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value
that you must supply.

Related Documentation

The following documents contain information you might find helpful as
you read this guide:

¢ Software Documentation

NI-DAQmx Base Help

NI-DAQmx Base 1.x Readme

NI-DAQmx Help

Getting Started with the LabVIEW PDA Module
LabVIEW PDA Module User Manual

LabVIEW Help, available by selecting Help» VI, Function, &
How-To Help

LabVIEW User Manual, available in PDF format by selecting
Start»Programs»National Instruments»LabVIEW 7.1»
Search the LabVIEW Bookshelf and clicking the LabVIEW
User Manual link

E Series Help

e Hardware Documentation

USB-9211 Operating Instructions
USB-9215 Operating Instructions
USB-6008/6009 User Guide
USB-6501 User Guide

CF-6004 User Guide

*  Documentation for the Personal Digital Assistant (PDA) device
you use

Overview

National Instruments measurement devices are packaged with NI-DAQmx
or NI-DAQmx Base driver software. NI-DAQmx Base includes an
extensive library of VIs and ANSI C functions that you can call from your
application software, such as LabVIEW or LabWindows™/CVI™, to
program all the features of your NI measurement devices. The NI-DAQmx
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Base driver software has an application programming interface (API),
which is a library of VIs and ANSI C functions for creating applications for
your device.

NI-DAQmx Base

NI-DAQmx Base is a driver that allows you to build applications that run
on a PDA and Windows. NI-DAQmx Base includes the following features:

NI-DAQmx Base is a subset of the NI-DAQmx API and is similar in
functionality to NI-DAQmx.

NI-DAQmx Base consists of a LabVIEW VI framework, which allows
you to customize the driver, if needed, when using LabVIEW.

NI-DAQmx Base provides a high-level interface on LabVIEW PDA
for Pocket PC 2003 and certain USB devices on Windows 2000/XP.

@ Note If you are familiar with NI-DAQmx, refer to the NI-DAQmx Base Readme for
information about the differences between NI-DAQmx Base and NI-DAQmx.

Device Support

NI-DAQmx Base 1.4 supports the following devices under LabVIEW 7.0,

7.1,

and ANSI C:

NI USB-6008
NI USB-6009
NI-USB-6501
NI USB-9211
NI USB-9215

NI-DAQmx Base 1.0.1 supports the following devices under LabVIEW 7.1
PDA for Pocket PC 2003:

NI CF-6004

NI DAQCard-6024E
NI DAQCard-6062E
NI DAQCard-6036E
NI DAQCard-AI-16E-4

@ Note For specific device model names or a list of newly supported devices, refer to the
NI-DAQmx Base Readme on the CD, or select Start»Programs»National Instruments»

NI-DAQmx Base.

NI-DAQmx Base Getting Started Guide
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Operating System, Application Software, Programming
Language, and Device Support in NI-DAQmx Base 1.x

Operating System Support

NI-DAQmzx Base 1.x supports Windows 2000/XP. The development
environment for devices on LabVIEW 7.1 PDA is supported on
Windows 2000/XP.

@ Note Only one version of NI-DAQmzx Base (such as NI-DAQmzx Base 1.4) can be
installed on the same computer at the same time.

Install Application Software

Install the NI application software, including LabVIEW,
LabWindows/CVI, and Measurement Studio. PDA users must use
LabVIEW 7.1 or later with NI-DAQmx Base 1.0 for Pocket PC. Refer to
the Operating System, Application Software, Programming Language, and
Device Support in NI-DAQmx Base 1.x section for more information. Also,
refer to Getting Started with the LabVIEW PDA Module and the LabVIEW
PDA Module User Manual for more information.

E Note PDA users should make sure LabVIEW PDA is completely installed and configured
before continuing.

Step 1. Install the NI-DAQmx Base Software

The following sections describe how to install the NI-DAQmx Base

software.
Insert the CD
@ Note Install your driver software before installing new hardware devices, or the operating
system might not detect your device, and you might see warnings asking you to install the

driver.

Inserting the CD launches the NI-DAQmzx Base install window.

If the NI-DAQmzx Base install window does not open automatically,
complete the following steps:

1. Select Start>Run.

2. Enter x: \setup.exe, where x is the letter of the CD drive.

3. Click Install NI-DAQmx Base.
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Install Support Files

The NI-DAQmx Base installer detects the NI software installed on the
operating system and automatically selects the latest versions of the driver,
application software, and language support files from the CD.

The NI-DAQmzx Base installer displays which features will be installed on
your computer, as shown.

4 NI-DAQMx Base 1.3 =101 %]
Features

; NATHONAL
Select the features ta ingtall. 'FlmmMENTS'

4]

= =3 ~| NI-DADmx Base 1.3 for Windaws
o Ee =3 -| LabVIEW 7.0 Support
=3 ~| LabVIEW 7.1 Suppart
= ~| C Support

=1 ~| Docurnentation

= v| M54 3.2
o= w| Ml Measurement & Automation Explarer 3.1 % :D

Thiz feature wil be installed on the local hard drive.

This feature and itz selected subcomponents wil
require 143 MEB of dizk space.

|

Directory for NI-DAQm: Baze 1.3 for Windows

Browse,.. |

Restare Defaults | Diizk. Cost... | <« Back I R | Caticel |

Complete the following steps to install NI-DAQmx Base.

1.

NI-DAQmx Base Getting Started Guide

In the Features window, shown in the previous figure, verify that the
installer detected and selected the correct support files and the correct
version number of the application software.

Click the + in front of the feature to expand the list of feature
subcomponents as shown in the previous figure. You can select
additional options to install the support files, examples, and
documentation.

Follow the software prompts.

Click Finish and wait for the installer to complete. NI-DAQmx Base
might require you to reboot your computer to complete installation.
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Step 2. For Devices on LabVIEW 7.1 PDA Only—Run the

PDA Setup Utility

After running the NI-DAQmx Base installation, you must copy the driver
files to the PDA. Complete the following steps to run the Pocket PC Driver
Installation utility.

1.
2.

Select Start»Programs»National Instruments»NI-DAQmx Base.

Click PocketPC Driver Installation. Clicking PocketPC Driver
Installation launches the Pocket PC Add/Remove Programs utility
window, as shown in the following figure.

5. Add/Remo |

Select a program's check box if pou want ta install it ot pour
mobile device, or clear the check box if you want ta remove the
program fram your device,

Mate: If & pragram that pou installed iz not listed, the program was
not designed to be uzed on pour mobile device.

Installing Applications x|

Inztall "M ational Instruments HI-DAG My Baze 1.0" uzing the default application install directon’?

Mo | Cancel |

Space required for selected programs:
Space available on device:
V¥ Install program inta the default installation folder

Femove from bath location:
To remove the zelected program from bath A
your device and this computer, click Remowe, D505

[0 I [Eance! | Help |

Click Yes to install the device driver into the default application install
directory.

Check the Pocket PC screen to see if any additional steps are requested,
such as replacing an older driver.

If there are no error messages, you have completed the steps to install the
driver files onto the PDA.

© National Instruments Corporation
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Step 3. Unpack the Devices, Accessories, and Cables

Your device ships in an antistatic package to prevent electrostatic discharge
(ESD) damage to the device. ESD can damage several components on
the device.

A Caution Never touch the exposed pins of connectors.

To avoid such damage, take the following precautions:

e Ground yourself using a grounding strap or by touching a grounded
object.

* Touch the antistatic package to a metal part of the computer chassis
before removing the device from the package.

Remove the device from the package and inspect the device for loose
components or any sign of damage. Notify NI if the device appears
damaged in any way. Do not install a damaged device in the computer,
PDA, or PXI chassis.

Store the device in the antistatic package when the device is not in use.

For safety and compliance information, refer to the device documentation
packaged with your device.

Step 4. Install the Devices, Accessories, and Cables

NI PCMCIA Device Installation

A Caution Follow proper ESD precautions to ensure you are grounded before installing the
hardware.

The NI PCMCIA device supports hot insertion on the PDA, which means
the NI PCMCIA device can be installed and removed without rebooting the
PDA. You can install an NI PCMCIA device in any available Type II PC
Card slot.
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To install the NI PCMCIA device, refer to the following figure while
completing the following steps.

1 PDA with Type Il PC Card Slot 4 NI PCMCIA Device 6 Accessory
2 Type Il PC Card Socket 5 1/O Cable 7 1/O Signals
3 PDA Expansion Pack

1. Attach the Type II PC cardsleeve or expansion pack to the PDA,
if necessary.

2. NIPCMCIA devices have two connectors: a 68-pin PCMCIA bus
connector on one end and an I/O connector on the other end. The
NI PCMCIA device is keyed so that you can insert it only one way.
Insert the NI PCMCIA device in the slot until the connector is firmly

seated.

A Caution Always grasp the cable by the connector you are inserting or removing.
Never pull directly on the I/O cable to unplug it from the PCMCIA device.

3. Attach the I/O cable. Be careful not to put strain on the I/O cable when
inserting or removing the cable connector.

NI CompactFlash Device Installation

A Caution Follow proper ESD precautions to ensure you are grounded before installing the
hardware.
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The NI CompactFlash device supports hot insertion on the PDA, which
means you can install and remove the NI CompactFlash device without
rebooting the PDA. You can install an NI CompactFlash device in any
available Type II CompactFlash slot.

To install the NI CompactFlash device, refer to the following figure while
completing the following steps.

1 PDA with Type |l CompactFlash Slot 3 I/O Cable 5 /O Signals
2 NI CompactFlash Device 4 Accessory

1. NI CompactFlash devices have two connectors: a 50-pin
CompactFlash bus connector on one end, and an I/O connector on the
other. The NI CompactFlash device is keyed so that you can insert it
only one way. Insert the CompactFlash device in the slot until the
connector is firmly seated.

A Caution Always grasp the device by the connectors you are inserting or removing. Never
pull directly on the I/O to unplug it from the CompactFlash device.

2. Attach the I/O cable. Be careful not to put strain on the I/O cable when
inserting or removing the cable connector.
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NI USB Device Installation

Complete the following steps to install an NI USB device.

1. Connect the cable from the computer USB port or from any other hub
that provides USB bus power to the USB port on the device. Connect
the other end of the USB cable to the USB port on the device. The
following figure shows the USB cable and its connectors.

‘ 1 Host/Hub/PC USB Port 2 NI USB Device USB Port

2. Power on your computer or PXI chassis. On some Windows systems,
the Found New Hardware wizard opens with a dialog box for every
NI device installed. Click Next or Yes to install the software for each
device.

Accessories

Install accessories and/or terminal blocks according to the instructions in
their user guides.

Step 5. Confirm That Your Device Is Recognized

The following sections discuss how to confirm that your device is
recognized.

Devices on LabVIEW 7.1 PDA

Pocket PC only indicates whether a hardware installation error occurred.
If there are no error messages, you have successfully installed the features
and the device is recognized by the NI-DAQmx Base driver. If you receive
an Unknown Device error message, you have not correctly installed
NI-DAQmx Base on the PDA. Refer to Step 1. Install the NI-DAQmx Base
Software for more information about how to install the Pocket PC features
of the NI-DAQmx Base driver.

USB Devices

To verify that the USB device is recognized, complete the following steps:

1. Double-click the Measurement & Automation icon on the desktop to
open Measurement & Automation Explorer (MAX).
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2. Expand Devices and Interfaces.

Verify that the device appears under USB Devices. If the device

does not appear, press <F5> to refresh the view in MAX. If the device
is still not recognized, refer to ni . com/support/install for
troubleshooting information.

& My System - Measurement f Automation Explorer
File Edit Wiew Tools Help

= @ ~
= Devices and Interfaces i
PXI PX1 System (Unidentiied) National Instruments
& Ports (Serial & Parallel)
B s ol pake Measurement &
9 UISBD:: 0x3923:: 07 0A6: FEFFFFFF: RAW Automation Explorer

+ Software

+ Remote Systems H
9 What is Measurement &

Automation Explorer?

Measurement & Automation Explorer || MAR displays
{(MaX) provides access to your interactive

National Instruments CaN, DAQ, embedded help
FieldPoint, GPIB, IMAQ, I¥I, Modular |1 the right
Instruments, Motion, NI Switch side Dflthe
Executive, Y1 Logger, VIS4, and vx1 || Max window to

? Category Help

4. Choose a VISA alias to identify the USB device in your application.
To create an alias, right-click the device name and select Properties.
Enter a new VISA alias and click OK to accept the changes. Confirm
the new name in the MAX Configuration window.

Step 6. For USB Devices Only—Launch Ready-To-Run
Datalogging Software

NI-DAQmx Base includes ready-to-run datalogging software for certain
analog input USB devices. This datalogging software lets you begin
making measurements without creating a program first. The applications
are located at Start»All Programs»National Instruments»NI-DAQmx
Base»Datalogging Software.

Step 7. Create and Configure Tasks

A task, an important concept for NI-DAQmx and NI-DAQmzx Base, is a
collection of one or more channels with timing, triggering, and other
properties. Conceptually, a task represents a measurement or generation
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you want to perform. You can set up and save all configuration information
in a task and use the task in an application.

Using the NI-DAQmx Base Task Configuration Utility

The following sections describe how to use the NI-DAQmx Base Task
Configuration Utility.

USB Devices with Windows

Using the NI-DAQmx Base Task Configuration Utility is not required
for USB devices. Most device parameters are adjustable through the
NI-DAQmx Base API. However, some advanced features cannot be
programmatically set and must be statically configured as part of the task.
With the NI-DAQmzx Base Task Configuration Utility, you can create
multiple tasks, each with a unique configuration, and switch between them
in your application.

Devices with LabVIEW 7.1 PDA

Using the NI-DAQmx Base Task Configuration Utility is required when
using devices with LabVIEW PDA 7.1. In NI-DAQmzx Base for Pocket PC
2003, task information is embedded in the built application. Prior to
building and downloading your VI to the PDA, you must configure and
save the tasks you want to use.

To use the Task Configuration Utility, complete the following steps:

1. Select Start»Programs»National Instruments»NI-DAQmx Base.

2. Click NI-DAQmx Base Task Configuration Utility. The Task
Configuration Utility launches.

DAGmx Base Tasks

dio read port

dio write port

ctr single pulse
ckr cont pulse

ckr simple event
chr buf event

ctr period

ctr pulse width

ai finite buffered
ai cont buffered
ai cont mulki

ai finite dig trig

ai cont analog trig
ai dig ref trig

ai dig start and ref trigs
ao finite buffered
ao conk regen

ao conk no regen
new task

EE NI-DAQmMx Base Task Configuration Utility ;Iglll

Task Configuration Parameters

Refresh Devices | Analog Input Voltage Task
Device
MI B062E: "Devz" {on Pocket PC 2003 device)

Channel List | Task Timing | Task Triggering | Advanced |

Create New Taskl Scan List

ﬂD - -
(Channel Gain Polarity ChannelType
Delete Task
—I ”&0 |1 JE3 |Bip0|ar =l |DiFFerentiaI |
Channel Gain Polarity ChannelType
1] 1 x| |Bipolar _=| |Differential _=

Import Task Lisk |
Channel Gain Polarity ChannelType
1] 1 x| |Bipolar _=| |Differential _=
Export Task List |

Save & Exit |
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@ Note You also can launch the Task Configuration Utility from within LabVIEW by
selecting Tools»NI-DAQmx Base Task Configuration Utility.

Create, Modify, and Configure a Task in
NI-DAQmx Base

Create a new task or modify an existing task in the Task Configuration
Utility task list. The pre-installed tasks are configured to work with the
examples without modifications. To modify an existing task, select it in the
task list. To create a new task, complete the following steps:

1. Click Create New Task. The Create New Task.vi window opens.

I Create New Task.vi =]

Create Mew DACM: Base Task
Task Mame
Meww Task

Device
MI 60AZE; "Deve" {on Pocket PC 2003 device)

1.C\cquisitinn Type
;) Analog Input

[o]4 I Zancel |

2. Enter a name for the new task.

Select the device. For devices on LabVIEW 7.1 PDA, select the device
that matches your installed hardware.

4. Select the acquisition type.

Each acquisition type contains a set of tabbed dialog boxes for configuring
the task.
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Analog Input Voltage Task
Drevice
MI A0GZE: "Deva" {on Pocket PC 2003 device)
Channel List | Task Timing ~ Task Triggering | Advanced |
Skart Trigger Reference Trigger Analog Trigger
Trigger Palarity Pretrigger Scans Analog Trig Mode
JRising = 1) 0 Juore =
Trigger Source Trigger Palarity Analog Hi Ref
JHone B | |Rising =l .‘-j o
PreTrigger Source ‘F\nalog Law Ref
|F‘F11 vI L}) 0
@ Tip You can view context help for the Task Configuration Utility by pressing <Ctrl-H>.

5. Click Exit when you are finished configuring your tasks. The task
configuration is automatically saved into LabVIEW global variables.
You do not need to explicitly save the configuration.

To transfer the task configuration to other computers, click Export
Configuration and save the tasks to a file. You then can use Import
Configuration to import the task configuration.

E Note The Import Configuration and Export Configuration options operate on the entire set
of tasks shown in the Task Configuration Utility. Importing a configuration replaces any
existing tasks, including the predefined tasks for the example programs.

Devices on LabVIEW 7.1 PDA

When you are using devices on LabVIEW 7.1 PDA, the task configuration
is built into the target application. You cannot retrieve the task information
after it is embedded in a built application. Exporting the configuration
allows you to preserve the task in case of accidental deletion when using
the Task Configuration Utility.
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Using Tasks in an Application

To use a preconfigured task in your application, complete the following
steps:

1.

2.
3.
4

Documentation

Right-click the task/channels in terminal on a NI-DAQmx Base VI.
Select Create»Control or Create»Constant.
Type the name of the task in the control or constant.

To set the value as the default for the control, right-click the control and
select Data Operations»Make Current Value Default.

The NI-DAQmx Base software kit includes online documentation for
supported devices and accessories, including PDF and help files describing
device terminals, specifications, features, and operation.

After installation, the documents are accessible from Start»Programs»
National Instruments»NI-DAQmx Base»Documentation.

@ Note You must have Internet Explorer version 5.0 or later to use some features of the
NI-DAQmx Base 1.x documentation, including the help system.

Getting Started Developing an Application

Examples

Each API includes a collection of programming examples to help you start
developing an application. You can modify example code and save it in an
application. You can use examples to develop a new application or add
example code to an existing application.

NI-DAQmx Base Getting Started Guide

NI-DAQmx Base examples for LabVIEW are located in the Program
Files\National Instruments\LabVIEW\examples\
DAQmxBase directory.

NI-DAQmx Base examples for ANSI C are located in the Program
Files\National Instruments\NI-DAQ\examples\
DAQmxBase\C directory.
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The following figure illustrates a typical NI-DAQmx Base application
in LabVIEW. The pictured task uses a preconfigured task to acquire and
display a finite number of points for multiple channels.

tazk/channels in tlmecuut

[% ai finite buffered [+| [10.00] jl’ r "“-]
. o

i =Frd s

Analog 20 DBEL
5 amplez per Channel MNChan NS amp

[13z¢

Devices on LabVIEW 7.1 PDA

Refer to Getting Started with the LabVIEW PDA Module and the LabVIEW
PDA Module User Manual for more information about how to create a
PDA application.

Obtaining Information about Measurement Applications and Devices

Each application software package and driver includes information about
writing applications for taking measurements and controlling measurement
devices. The following references assume you have NI-DAQmzx Base and,
where applicable, LabVIEW 7.1 installed on your computer.
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LabVIEW

If you are a new user, complete Getting Started with LabVIEW to
get acquainted with LabVIEW. Select Start»Programs»National
Instruments»LabVIEWx»Search the LabVIEW Bookshelf.

The LabVIEW NI-DAQmx Base VI Reference Help describes the LabVIEW
VIs and properties. In LabVIEW, select Help»LabVIEW Help and the
VI reference help section for NI-DAQmx Base.

ANSIC

The NI-DAQmx Base C Function Reference Help contains an API
overview. Select Start»Programs»National Instruments»NI-DAQmx
Base C Function Reference Help.

Training Courses

National Instruments offers training courses for those interested in
receiving more help developing an application with NI products. To enroll
in a course or obtain a detailed course outline, refer toni . com/training.

Worldwide Technical Support

For additional support, refer to ni.com/support or ni.com/zone.

For further support information for signal conditioning products, refer
to the Signal Conditioning Technical Support Information document
packaged with your device.

National Instruments corporate headquarters is located at 11500 North
Mopac Expressway, Austin, Texas, 78759-3504. National Instruments also
has offices located around the world to help address your support needs.

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni . com/legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products, refer to the
appropriate location: Help»Patents in your software, the patents . txt file on your CD, or
ni.com/patents.

© 2004 National Instruments Corporation. All rights reserved. 371259B-01 Dec04
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